IT HAS BEEN RESOLVED
Incident Report for Easyship
Resolved
This incident has been resolved.
Posted Feb 01, 2021 - 18:34 UTC
Investigating
eBay API check failed
Posted Feb 01, 2021 - 18:31 UTC
This incident affected: API (eBay API).