IT HAS BEEN RESOLVED
Incident Report for Easyship
Resolved
This incident has been resolved.
Posted Feb 19, 2021 - 03:37 UTC
Update
Easyship Web App check failed
Posted Feb 19, 2021 - 03:23 UTC
Investigating
Easyship Website check failed
Posted Feb 19, 2021 - 03:23 UTC
This incident affected: Easyship Web App.