Tracking Page Security Update

Incident Report for Easyship

Resolved

We are continuing to monitor for any further issues.
Posted May 17, 2022 - 04:47 UTC

Update

We are continuing to monitor for any further issues.
Posted May 17, 2022 - 04:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 17, 2022 - 04:12 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 17, 2022 - 03:29 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 17, 2022 - 03:27 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 17, 2022 - 03:25 UTC
This incident affected: Tracking Page.