Cloudflare Global Network experiencing issues

Incident Report for Easyship

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 20:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 15:41 UTC

Identified

We are experiencing the Cloudflare issue. All services are intermittently impacted.
https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 13:56 UTC
This incident affected: API (Core API, Open API, Rates API, API-E, API-S) and Easyship Web App, Tracking Page, Easyship Website.